Audio+ v2 outputs only mono audio [resolved]

I recently bought a Raspiaudio audio+ V2, and I mounted it on a Raspberry Pi 0W (first model), with a fresh RaspberryPi OS install.

I then configured the sound card with the command:
wget -O - | bash

Machine rebooted, tested audio and I can hear both channels on both speakers.

I tested various setups to exclude malfunctioning audio cables/speakers, but the issue seems to be confined to the RPi/sound card.
I also checked both the 3.5 mm jack and the RCA output and they both show the same issue.

Hi and welcome!

When you type :

speaker-test -l5 -c2 -t wav

1-Can you hear “front left” on the left then “front right” on the right?
2-Have you tried a clean installation from a fresh SD card and tried again?

If you have answered 1-No and 2-Yes, you might have a defective unit then asked for a refund.replacement thru your local Amazon.

Sorry if this is on us!

Good morning,

Upon executing the command I hear both sounds on both left and right speakers.

Just to be sure I double checked everything and clean installed from scratch two times.

At this point I really think I got a defective unit. I will proceed with the replacement of the product.

edit: typo