Can't get the Audio+ to work [closed]

I’ve put on the Audio+ hat on my Rpi Zero W, flashed a new Raspberry OS 32 bit from today, ran the bash script, but I can’t get any sound out of the 3.5 mm jack whatsoever.

If I go to raspi-config > System settings > Audio, it tells me “no internal audio devices found”. I can see the devices in alsamixer, I can change the volume, but not sound out of the headphones. The speaker-test script runs, but I never hear anything. No output of audio works (tried with aplay too).

  1. Is /boot/config.txt supposed to have both dtparam=audio=on and dtoverlay=hifiberry-dac on at the same time? What else am I missing? :frowning:

Hi Crashoverride!
Do you have any other shield, LCD screen installed that could cause a conflict, any other software installed than the regular Raspbian? If yes try again from a new SD card without anything else than the AUDIO+ plugged on the GPIO.

If you have done that and still have no sound, can you send me a picture of your setup with the shield on the Raspberry pi zero?


I re-flashed the SD-card with a brand new raspberry OS 32 bit, just to eliminate any conflicts. No other hardware attached, except the HDMI for monitor and USB for keyboard.


  1. Installed OS
  2. Ran raspiaudio installer script
  3. Rebooted
  4. No audio

So, I’ve made a bunch of config, both in /boot/config.txt and raspi-config, but nothing seems to work.

UPDATE: I got audio, but ONLY on HDMI out (speakers on my darn monitor)! If I change in raspi-config > System options > Audio > (headphones), instead of HDMI, it doesn’t seem to stick - still HDMI out.

Suggestions? Can I override that with /boot/config.txt?

Alsamixer tells me there are three cards under /proc/asound/cards:

  1. b1: bcm2835_hdmi
  2. Headphones: bcm2835_headphones
  3. sndrpihifiberry: RPi-simple - snd_rpi_hifiberry_dac

However, raspi-config only gives the options:

  1. HDMI
  2. Headphones

If you use plain Raspbian with the install script then the test scrit you should have nothing else to do.
So the issue could be on the hardware, damaged board (very rare) or bad connection can you take a picture of your connection on the zero I guess you had to solder it yourself.

Yeah, and that’s the reason why I re-flashed the whole SD card to get a fresh start. It’s still not working. I’m getting audio on HDMI, but never from the Audio+.

I did solder it myself, and while it’s not the prettiest solder job in the history of solders, I can’t see how all the pins wouldn’t be connected. A bunch of cold solders/joints, but yeah… I had the same idea that you suggest. So, I did order a pre-soldered rpi Zero W (I think it’s labeled WH?), it will arrive later today.

I’ll try it and get back to you. Thanks for your support!

Ok wait for you other Pi to arrive, if this is still not working ask for a free replacement on your Amazon account. Sorry if the issue comes form us, this Audio+ is usually quite reliable.

Hello, have you been able to solve this issue?

subject closed due to inactivity, reopen it if needed