End of my wits with flashing new firmware

So my friend saw this speaker at a garage sale and decided to get it for me randomly. But the speaker doesn’t seem to be turning on. There’s no power to the LED on the top below the buttons but the charging led at the back does light up and blink, but nothing shows up on my phone’s bluetoot.

I started by trying to flash factory firmware to it but whenever I try to flash the terminal window just says ‘case ok, no log file output’.

Then I tried to go the arduino compilation route and got the error " #error Architecture or board not supported.
#error Architecture or board not supported."

I then randomly stumbled on a youtube video that allows flashing online which I tried and surprisingly the my speaker showed up but it kept searching for wifi networks in an endless loop. Which leads me to believe that there is life in this speaker but I’m just not sure how to get it to work at this point. Any help would be greatly appreciated.

I’m pleased to discover that there’s a second-hand market for Luxe devices! From your description, it appears the device isn’t physically damaged but may be experiencing a software or firmware issue, which can sometimes hinder smooth updates.

I recommend starting with a basic approach. Please visit apps.raspiaudio.com and use the “Bluetooth” application.

To initiate a forced firmware update, please follow these steps:

  1. Power off the device.
  2. Utilize a paper clip or a similar tool to gently press a hidden button accessible through the audio jack. You should feel a click. Continue to hold this button down while you power on the device. This action should trigger the forced update mode.
  3. Attempt to reinstall the firmware.

If the issue persists, try pressing the jack button again while the software is searching for the device.

Please keep me informed of your progress.