ESP Muse proto: no audio [under investigation]

Hi there

I’ve been trying tot get audio playing via de ESP Muse Proto, but do not succeed.

1st started with ESP Squeezelite. Bluetooth played audio, but AirPlay showed a device, but could not connect. Integration with Home Assistant ok, but no audio will play if selected from local media.

Then found your easy installation guide and installed successfully. No bluetooth available, but now in Home Assistant I can see 3 entity’s and control the onboard LED when connected via WiFi. So it seems that Home Assistant is able to communicate with the proto board. But playing mp3/wav from Home Assistant is not working; no sound from builtin speaker or external speaker connected to the green terminals.

So I’m stuck now on resolving the audio problem. Any suggestions for me to troubleshoot this issue?

BTW: in both scenarios (easy installation and Squeezelite) the blue on board LED is flashing. Did not find and documentation on what that means. So, any clues on the status description of the blue LED?


So in Squeezelite in Bluetooth you have some sound coming out, correct?


That is correct.
AirPlay not working. Can’t connect


Esp muse and HomeAssistant are in the same network (

For airplay, did you tried to connect with a browser to the Squeezelite web interface (you can get the IP address of your Lan looking at the serial log console, or in your router settings). From their be sure that AirPlay is enabled.

I tried and did not succeed.

Put the focus now on the simple implementation and get audio/tts from Home Assistant. That is my main goal. I thought that required Sqeezelite, but apparently not. That eliminates some possible interactions/causes I think

As you prefer, post your results here please

Well, i started this topic with the result of that installation…

Any one having a suggestion for tests or adjustments that lead to a step forward to a solution?


After Squeezelite-ESP32 gets flashed again, you need to make shure you exit “recovery Mode”.
You can try to do a OTA update. 16 bit version is recomendet.
If that dosn’t help, maybe tell us what version your on.

please share any logs an you HA version, there is maybe an issue as I have 2 reports for a similar issue.

I can confirm that there is an issue with the Muse Proto with Home Assistant when using the ESP Home firmware working on it with the HA team.
But this is working fine using the Squeezelite firmware in Home Assistant, don’t forget to install in HA the Squeezebox add on

Thanks for informing. Is there a pr for it?

In my HA log there is no problem reported that relates to media player

My HA version is 2022.7.6


Hi, still under investigation, I’ve sent a Muse Proto to the HA team they will look at it. Stay tuned.

Is that not an indication LED for the Battery charger, that is what i expected to be?

I have the ESP Muze Proto working (somewhat) using esphome and Home-assistant and i can do TTS fine. The only issue i have with the board is that the speaker sound is way to weak,
i already boost it up to 15db but still when the device is to var away you do not notice that is saying something.

I tried to look about what the current issue is, could you tell me what is still wrong on your side?
When you do, i can test it here to see of i can reproduce and may be help figuring out what is going one.

Hi Niels

According the picture on this website it can be the charging LED. But the flashing and brightness of it are very annoying while the board is not in a case :wink:

Do you know a way to switch this LED off?


Hi Niels

Lucky you! Mine does not play audio (mp3/wav) or TTS.
I can control the on board RGB LED and sense a button press in Home Assistant. So I conclude setup and communication via WiFi are ok.

Saw dr ZZZ’s video last weekend and he got it working although he had to adopt the board in the ESPHome environment, which I didn’t have to do. He could not play TTS btw.

So maybe the audio is not playing from my board due to the setup I have.

This is my setup: Intel nuc i3, Ubuntu 20.04.4 LTS, HA release 2022.8.5 in containers (as unsupported). I don’t use HA cloud.
Since a few HA releases back my VLC-Telnet setup stopped playing audio, which could be related to my issue?

In this topic it was stated there is a problem with HA and that a proto board is sent to the HA team. No details on the problem are described. Progress is unclear.

Any help is appreciated!


I use the following yaml code:

  board: esp-wrover-kit
    type: arduino

    priority: 10
     - lambda: |-
          gpio_set_direction(GPIO_NUM_23, GPIO_MODE_OUTPUT);           
          gpio_set_pull_mode(GPIO_NUM_23, GPIO_PULLDOWN_ONLY);
          gpio_set_level(GPIO_NUM_23, 0);    

  - platform: i2s_audio
    id: media_out
    name: my player
    dac_type: external
    i2s_lrclk_pin: GPIO25
    i2s_dout_pin: GPIO26
    i2s_bclk_pin: GPIO5
    mode: mono
      number: GPIO21
      inverted: true

Could you conform that you have your ESP Muse proto is configurated the same way?
The first part below the on_boot is optional and should give a louder sound.

BTW. when you on the esphome discord server you can ping me there, im not an expert but we can compare our setups to see what the differences are.

Hi Niels

Opening the ESP32 integration in HA and edit my node shows this code, which probably is default:

name: raspiaudio-muse-proto-d40a44
raspiaudio.muse-proto: github://esphome/media-players/raspiaudio-muse-proto.yaml@main
name: ${name}
name_add_mac_suffix: false

ssid: !secret wifi_ssid
password: !secret wifi_password

I wil add your code and see what happens


Hi Niels

Edited the configuration yaml to match yours. It compiled, connected to the device, OTA uploaded successfully.
Then it tries to connect using the esphome API and fails due to ‘Error resolving IP address [Errno -2] Name or service not known

It looks like the upload destroys the wifi setup. In the top of the installation log it reports that it is installing ESP8266wifi. But that is not correct I think?

Only way out of this problem is to reinstall the firmware, which brings me back to where I started.
Any suggestions?

BTW: I’m not on Discord