How to enable an equalizer on AUDIO+ [resolved]

Hi, I hope everyone is good and safe :slight_smile:

I’ve a Raspiaudio Audio+ dac and so far I was very happy with its performance. I usually connect it through line in (mini jack to mini jack) to an old stero speaker.

But I’ve tried to connect it from minijack to a phono entry in a home media center the bass are to high and I’m finding a lot of difficulties on having an equalizer work.

My installation is pretty plain, raspbian + the steps on the AUDIO+ installation + raspotify to stream from my mobile.

I’ve followed the steps described in here to install amixer equalizer plugin

They seem not to work, so instead of building an rc file on the home directory, I’ve tried to modify the audioconfig under /etc as:

type softvol

slave.pcm “plughw:0” “Master”

control.card 0 }

pcm.!default {

type plug

slave.pcm “raspiaudio”

type equal

type equal
slave.pcm “raspiaudio”

pcm.equal {
type equal
slave.pcm plugequal

In any case, when I play with the equalizer, the sounds doesn’t seem to have any variance.

Does anyone know how could I equalize the mini jack output on the raspiaudio?

Looking forward to hearing from you soon!

Best regards

Hi it0,

So yes it is possible as I did used alsamixer in the past with Audio+, now I’m not really sure how I did it.

But my advice is to try this guide form competition:

If this is not working try again form a fresh install of Raspbian.

The genral rule is that all literature on other brands of I2S dac will work on your RASPIAUDIO as we all use the same drivers.

Kind regards

Thank you, based on your entry I was able to see the real deal here… i

Specific applications

The equalization works only when the application uses the default output device from asound.conf. Applications that are configured to use the hardware device directly (you might see “hw:0” or similar in the command line options or in the configuration file) won’t use the equalization plugin.

so it’s not only about the .conf file but also the app needs to send the audio throught the equalizer as stated in the hifiberry. In my case, and just for the shake if anyone elses is in the same situation, for raspotify adding this to the /etc/default/raspotify does the trick:

OPTIONS="–device equal"

restart the service and to equalize:

sudo -u raspotify alsamixer -D equal

Thanks for geting me in the rigth track :wink: