Mic+ No audio on YouTube, but test plays fine [resolved]

I’ve running a Pi400 with the default Raspian OS, and the Mic+ plugs nicely into the GPIO connector on the back of the keyboard case. I can successfully run the test, and get plenty of volume. However, I get no audio out of YouTube on Chromium, despite carefully checking that audio isn’t muted. I’ve made sure that I"m not sending audio out the HDMI port (by patching /boot/config.txt), and both the CLI and GUI volume controls appear and can change values. The blue speaker icon in the upper right of the menu bar shows I am connected to the Mic+ board, as does the CLI audio utility. What am I missing?

One think I just noticed. If I go to raspi-config > System settings > Audio, it briefly flashes “no internal audio devices found”, then closes. I thought there might be a conflict with something built into the Pi400, but there is no audio hardware on this machine at all, unlike the Pi4, which has basic audio in and out jacks. So possibly something else needs to be turned on to get audio out on the Pi400?

I’ve tried uninstalling and re-installing, and removing pulseaudio and reinstalling that. Still no Youtube audio The failure happens with Vimeo as well. I can run pi-specific audio apps such as various games, and pisound and the audio output from that sounds good across the whole tonal range, and volume is excellent. Is there something special needed for YouTube/Vimeo audio?

Hi! is the problem on all websites on Chromuim or only Youtube/vimeo?
Do all other apps on the desktop output audion on the MIC+?


I found the problem. Apparently there is a bug in Chromium related to the pi400 in which it doesn’t recognize the audio system for that board ID. Chromium just issued an update fixing this on 11/18:


I installed this update and the audio plays on YouTube and Vimeo perfectly!

Great! thanks for the update