MIC+ not working for Raspberry pi 5 on ubuntu


I had the MIC+ installed on the pi 4. Recently bought a pi 5 and trying the same installation procedure (on Ubuntu Server 23.10) but getting an error for aplay-l: “the soundcard is not detected”

I have copied the overlay directory to the /boot/firmware/ directory. The versions are slightly different than the installation guide, so maybe that is an issue. For example ubuntu shows 2 different directories containing googlehat-soundcard drivers and I’m not sure if it matters which one is chosen.

If this should work then maybe someone can help me understand the possible sources of error?


Hi, have your tired this?

“I got sound working by editing /boot/firmware/config.txt. I commented out the line dtparam=audio=on and I added at the end the line dtoverlay=hifiberry-dacplus. I rebooted. aplay -l now has card 0: sndrpihifiberry. The sound is quieter than it should be, but at least I hear something.”

Mic+ is a pure I2S device so all recipes from competition should work on it, let me know how it goes.

I just tried using the hifiberr-dacplus overlay and it also doesn’t work. It seems to be related to a change in pi 5 hardware. I found the following two related issues:

This seems to sovle the issue for pi os. I tried the method they suggested “dtoverlay=hifiberry-dacplus,slave” but that doesn’t work for me (on ubuntu).

Another person is using ubuntu 23.10 on Pi 5 with a different DAC and they also can’t get it to work:

So for now it seems this may not be possible on a Pi5 with Ubuntu 23.10, until a higher power intervenes.

Hi, we confirm that I2S not working on UBUNTU + Pi5, affecting all brands of I2S sound card, we are looking for a workaround.