MIC+ problem in raspbian desktop [resolved]

Hi at all, I’ve bought two raspiaudio mic+ to my project about an intercom SIP based.

I’ve used the first Mic+ to make the doorbell. This is configured with a Rpi 3B, Mic+ and the camera module. I’ve installed the raspbian (buster) lite and build the linphone SIP client and it works very well.

I’ve used the second Mic+ hat to make a video desk. This is configured with a Rpi 3B, Mic+ and official 7" Rpi touchscreen display. Also in this configuration I’ve build the linphone SIP client with desktop user interface because i need the h264 and g729 codec that the repository version don’t have. In this configuration I’ve much problems with the microphone because the volume is too low and it’s unusable.

As sayed in the Mic+ installation post, i’ve tried to change the raspberry board, to switch the raspiaudio boards, I’ve installed raspbian stretch, buster and sid, I’ve tried to use others sip client to test, like jami or also the linphone present in the repository but nothing to do. In one case I’ve uninstalled the pulse audio from raspbian buster and using jami the microphone has worked.

So, i think that could be some differences whith the management of the Mic+ board using the raspian desktop enviroments.

Can someone help me?

Thank you very much

So I uderstand that the problem is that the volume is too low when used in your video desk project.

-The hardware is not faulty if it is working in your intercom project
-Alsa sound system uses the hardware microphone device and the installations script creates also a soft device where you can adjust to volume. When you type alsamixer try to raise the volume and run the test script again. You should hear a difference.
If in your other application the volume is too low you might be using the hardware microphone and not soft volume device, so you need to indicates to your app to use the soft device, this will help you to understand:

Hi, thank for your reply, but I’ve found thath the only solution is to uninstall pulseaudio. Linphone desktop let me to choise wich peripheric to use but there’s no difference because pulseaudio dominate the alsa controller. When I run alsamixer the default peripheric is pulseaudio and if I choose alsa it say to me that there is not hardware interface. So I’ve uninstalled pulseaudio:

sudo apt remove pulseaudio --purge
sudo apt autoremove --purge
sudo /etc/init.d/alsa-utils reset
sudo reboot
sudo apt install pimixer

And now it works perfectly

Thanks you for sharing the solution :smiley: