Mic+ Raspbian Bullseye no volume control via alsamixer

Cant get volume control via alsamixer to work on fresh installed Raspbian bullseye.
Sound and Mic working well but volume is always at 100%.

Anybody with similar problem or maybe a solution?


Hello and welcome,

Sometime Alsamixer requires you to play something on the device and to reboot, have you tried that?

Also, you will notice that for volume control the batch file creates a soft volume device that is based on the hardware volume device. If your application is using the hardware volume device and not the software device you will not be able to control it. So what application are you using? and are you sure that you are using the soft alsa device?

Kind regards,


Finally the solution for me was to modify the /etc/mpd.conf
1 -> set default audio output Google voiceHAT SoundCard …via raspi-config or via Desktop

2 -> put this in mpd.conf

audio_output {
type “alsa”
name “My ALSA Device”
mixer_device “hw:0”
mixer_type “software”
mixer_control “Speaker”
mixer_index “0”

Finally I can control the volume on my MagicMirror via voice-command and MMM-GoogleAssistant.

Thanks for support!

Thanks for the reply but still no volume control for my MagicMirror project :frowning:

I did a fresh installation of Raspbian Buster, installed Mic+ as written in install guide and changed Soundcard to google voiceHAT SoundCard HiFi voicehat-codec-0 in raspi-config.

Also changed the mpd.conf to use alsa for audio output.

I can now control the volume of mpd and aplay via alsamixer.
The MagicMirror GoogleAssistant module works with HTML5 audio as written on the install page but i can not control the volume via alsamixer.
Same problem with mpg321 player.

I set the volume in alsamixer to 50%
-> mpc plays radio at 50%
-> mpg321 and HTML5 audio is still at 100%

I guess mpg321 and HTML5 audio are still using the hardware volume??
Is there a way to control them also with alsamixer when using raspiaudio Mic+??

This small sized sound card would be perfect for MagicMirrors if this problem can be solved.


Hi this is not an hardware malfunction, but more an Alsa / Google Assistant issue that will be happening with any brand of sound card on the market.

This being said it looks like it is something to set in the Google Assistant configuration to point on the software volume Alsa device. I haven’t look at the Google Assistant for a while, what distribution are you using?