MIC+ V2 low Microphone volume


I am a new user and happy with my MIC+ V2 hat with my raspberry zero 2. In general the HAT has worked well in terms of recording and playback. I decided that I wanted to use external speakers instead of the built-in ones, so I followed the instructions, cut the track at labels ‘JP3’ and ‘JP4’ and connected external speakers to the terminals on the board. The speakers work great with strong sound - yay!
However, I noticed that now the microphone recordings became noticeably lower after connecting the external speakers. When I use the test script (wget -O - test.raspiaudio.com | bash) or record from a Python script, the recording volume is very low. It doesn’t seem to be related to the speakers, because when I play any sound, it plays back at normal, loud volume.
I also played around with the settings of alsamixer (see screenshot), but that doesn’t seem to have any effect on the recording volume in any way.
Strangely, when I record with arecord from the terminal, the recorded file is extremely noisy, unlike the one with the test script.
Does anyone have any idea how to fix this problem or know how to increase the recording volume?
Thank you very much!

Hello Harry

Strange, the volume of the microphone should not be affect by the external speaker because it is an I2S microphone with no external bias, unless there is a big voltage drop due to a low impedance speaker, do you have a low voltage system warning? if so have you try a bigger power supply?

for the sound quality, you have to set the sampling quality, here how it is done in the test script:
#record 5s
arecord -d4 -f S16_LE -c1 -r44100 /home/$USER/test.wav&

otherwise one trick is to create a virtual ALSA device to amplify the microphone, on the top of my head this should be something called type softvol to change in the asound.conf file.

Thank you for the reply!
I tried your test script and the sound was indeed crystal clear, although still very quiet. If I play any other sound than the recording, it the output volume is much louder. I also remember the recordings were somewhat louder before I attached the speakers. I attached 2x 1W 8 Ohm Speaker to the HAT.

But maybe it is a wrong mic setting? My asound.conf file looks like below. I played a bit with the micboost settings, but couldn’t notice any significant changes. I would be super thankful for any additional input!

options snd_rpi_googlevoicehat_soundcard index=0

pcm.softvol {
type softvol
slave.pcm dmix 
name Master
card 0

type softvol
slave.pcm dsnoop
control {
name Micro
card 0
min_dB -5.0
max_dB 50.0
resolution 256}

pcm.!default { 
type asym
playback.pcm "plug:softvol"
capture.pcm "plug:micboost"

ctl.!default {
type hw
card 0