Mn Cast not turning on or detected by computer

I just received my Mn Cast, and it neither turns on (nothing on the display and no indicator LEDs on), nor is detected by the flasher on Chrome when connected to my computer. Is this just a defective unit or is there something I can try to get it working on my end? I tried moving the switch to both positions, as well as holding the silver button, as well as press-and-holding the (I assume) reset button in both switch positions. I tried several different USB C cables and devices, all with no lights turning on. I opened the case and there’s some text on the back of the PCB that says (I think) “Test” and “Upload”, along with a nearly-wiped-out “X”. None of the soldering points look off, but I’m not an expert there.

Sorry for that, please ask a replacement thru Amazon. you should receive it very quickly.

Okay thanks, I requested a refund and ordered a new one. Hopefully this one arrives before I leave.

Wow does this seriously require a USB-A to USB-C cable, and not work without a USB-C to USB-C cable?? And you haven’t even DOCUMENTED that anywhere??? So my Christmas present was delayed and returned to me because you didn’t put in a $0.02 resistor and can’t manage to even document that incompetence?!? I really liked the goals of this project, but I have 0 confidence in the people behind it now; I’ll be returning this second device to Amazon and writing a review.

This is an extremely well-known problem and there’s absolutely no excuse, in 2023, for not knowing how to implement literally the most basic function of USB-C: charging at 5V. Four years ago, this was all over the internet: How to design a proper USB-C™ power sink (hint, not the way Raspberry Pi 4 did it) | by Benson Leung | Medium

I’m very disappointed.

Hello Californian,
The Mn Cast does have the mandatory 5.1kohm resistors on CC1 CC2 to be detected as a 5v device by USB C power supply.

If I understand correctly your issue is that you plug a USB C to USB C cable and your USB serial is not recognized? but it works with a USB C to USB A?