Modulox only working when connected to a PC? is this right? [resolved]

hello again, i figured out my other issue, but i now cant get the modulox to run when not connected to a pc, i loaded my stuff, it works, then i connect it to a mobile usb power supply like a ripcord, it seems to remember my set. as the lights work, but it wont run anything, i bought it to control hardware because of the midi port jack, does it have to be connected to a pc to work? or can i use some form of power supply, idk its remebering my lights set but wont send notes? please help

Hello, when you connect with an external power, you have to use the MIDI out with jack. Do you have a jack-MIDI DIN cable ?

Hello, yes I have a 3.5 midi to din, I was using a type b I believe when connected to the computer sending output to my hardware and it was working, but when I unplugged it, and plugged it into an external power supply, it stopped working, I also have a type A but I figured just leave the one in that was working, it’s weird cause it turns on, but it won’t send midi messages anymore, any clue why this is the case? Is my external supply not giving it the exact voltage it needs? It seems strange, I tried plugging it into my Akai MPC which functions as a USB host and it works via the midi out, but not with my basic power supply, the midi out stops again?? I would like to use it without being connected to a USB host… is this possible?

Additionally, I tried with 3 different USB power supplies that all work and power my Roland tr6s fine, so it’s not that they are not giving power…

OK, I will try at home. The problem is not the cable USB or MIDI. It’s just that when you don’t connect to PC, the modulox is working in a different mode. I will try and fix it.

Hello, did you figure anything out? I’m at a loss of what to do…

we are working on the issue, coming back to you soon.

Hello, here is a link to a modified 0.38 firmware:

You can load it with STM32CubeProgrammer:

When modulox plugged into DFU mode (up right button pushed before plug), click on “connect” in CubeProgrammer, then click on the “add” sign, and open the .hex file. Then click on “download”.
Be careful, this firmware is a modified version of 0.38 firmware. You can only use it on the master module (not the slaves if you have several modules). This feature will be native in the future v0.39. Tell us if it’s OK.



Hi, sorry I just saw it and tried, for some reason the cube programmer could not find the device? I switched it to USB dfu mode and it couldn’t connect it says error cannot estiblish connection with device? I’m not sure what I’m doing wrong, I tried loading it with the dfu loader demo, but since it’s a hex file it says the file is not supported, it’s like there is no driver for it for the cube programmer? I booted in in dfu mode but I can’t get it to connect to the device… any recommendations to let the cube programmer see the device?

Ok, I figured it out, I’m still slightly confused as to what exactly got my computer to see it, but it did, I installed some sort of development kit for USB devices which had some drivers and it saw it. I loaded the firmware, it appears to be functioning well! Thank you for the help.

I just tried one more test with a slave attach, so the slave lights up, but it doesn’t send it’s midi data to the host, so the host can send it out the midi port of the host, and with a midi port connected to the slave it doesn’t send out it’s midi data either, I saw that you said don’t install it on the slaves, so I didn’t, but they won’t function, the host one that I installed it on runs perfect, I have it connected without a computer and it still sends it’s data, if you have any ideas or think I should upgrade the slave a will but I figured listen to you guys since you made the code, but the one I updated runs how it should… which is good.

Hello, sorry for the reply delay. On the master (the one connected to synth) you have to upload the modified firmware, (that forces the master mode), and on the others, you have to leave the normal firmware. And all the modulox have to be plugged together before pluging usb power.