Muse Proto not updating in ESPHome

Hi, anyone else having problems updating after 23.12 in ESPHome. It is only my Muse Proto refusing, I have two Muse Lux updating just fine.

Failed config

speaker.i2s_audio: [source :48]

Pin 26 is used in multiple places.
platform: i2s_audio
id: board_external_speakers
i2s_dout_pin: 26
mode: mono
dac_type: external
media_player.i2s_audio: [source :55]

Pin 26 is used in multiple places.
platform: i2s_audio
id: media_out
name: ‘’
i2s_dout_pin: 26
mode: mono
mute_pin:
number: 21
inverted: True
mode:
output: True
input: False
open_drain: False
pullup: False
pulldown: False
ignore_strapping_warning: False
drive_strength: 20.0
disabled_by_default: False
i2s_comm_fmt: msb

Hi, I’ve tried and it works fine for me. Try updating in bootloader mode, by turning your Muse Proto off, then press the io0 button next to the speaker header and keep pressing it while at the the same time turning your Muse Proto back on

Same issue here. Powering on while pressing the io0 button and then updating via OTA didn’t work out for me. Received exactly the same error.
Issue seems to be caused by the latest update of Raspiaudio/ESPhome. Are they going to fix this? I have just a vanilla setup without any tinkering of pins etc.

trick with pressing the ‘io0’ button doesn’t work for me either. I get message ‘preparation failed’.

The error occurs on compilation, not loading, so “pressing the boot loader button” is irrelevant.

Yes, this error is still present today, it has been for many weeks. when one uses this line:

packages:
raspiaudio.muse-proto: github://esphome/media-players/raspiaudio-muse-proto.yaml@main

It seems like noone is maintaining the image on github. bemble and jesserockz are the ones with earlyer commits

Just for anyone who hasn’t been able to get this fixed yet,
I found that the original github esphome repository has been archived and everything moved to a new one.

The updated raspi proto package ( that also appears to include a fix for the pin issue ) is here:

by trial and error I believe the github URL to include in the packages config is:

packages;
raspiaudio.muse-proto: github://esphome/firmware/media-player/raspiaudio-muse-proto.yaml

Good Luck

2 Likes

@diego is shedule to make a tutorial for Proto on Feb 4th hope it will help@Diego is scheduled to make a tutorial for Proto on February 4th. Hopefully, it will be helpful. stay tunned

1 Like

Hello @Raspiaudio / @diego , Please advise where can we find this tutorial please, because my Protos have been useless for several months now ?

The GIT repo yaml does not seem to have been updated either.