New Mic+ V2, no sound at all


I just bought a Mic+ V2 and installed according to the Installation guide.

Unfortunately, it seems it is not working: when running the test script ( wget -O - | bash) the card remains totally silent.

I am sure it is plugged in correctly into the Raspberry header: the LED and button work fine, and I also tried reconnecting it multiple times.

What I also noticed is that neither the desktop applet, nor AlsaMixer recognize the board:

Screenshot from 2024-02-16 23-01-29

My Raspberry is a Pi 4, fresh install, 6.1.0-rpi8-rpi-v8 #1 SMP PREEMPT Debian 1:6.1.73-1+rpt1.

Can the hat just be faulty? Should I return it? What should I do?

I found a partial reason for the failure: the installation script adds dtoverlay=googlevoicehat-soundcard to /boot/config.txt, but now that file has been moved to /boot/firmware/config.txt. I think it also checks the cmdline.txt file, which has also been moved to `/boot/firmware/'.

So you should definitely update that script: you just need to update the lines that reads:


Changing those lines, at least, the board is recognized by the Pi:


Unfortunately, there are still some residual problems: running the test, now the audio comes out, but the recording function does not work.

Also, running AlsaMixer,

So… something solved, something still needs addressing.

Any suggestions?

Hi luca,
same problem here and the same thoughts :smiley:
I changed the two lines in the script




and got as far as “This sound device does not have any controls.”

Maybe there is no firmware with the current raspberry image for the googlevoicehat-soundcard?

The Firmware seems to be fine. When I increase the pulseaudio input volume in alsamixer to 100%, I can hear my recording. Its just a bit quiet.
So the asound.conf in the script doesn’t seem to work correctly. I would expect that it enables the volume setting on the googlecoucehat_soundcard.

Hello guys,

I have tried again this morning and it is working check that you did the same starting with a new SD card to try:
-Took a fresh SD card and burnt RPI OS 64bit Bookworm Released 2023-12-05
-Inserted it in my RPI5 with on top the MIC+ hat
-Opened a terminal and typed :

wget -O - | bash

-When prompted to, I rebooted
-Back on the desktop right click on the speaker on the top right corner to select the device “snd_rpi…”
-Opened a youtube video and can hear the music

Then in alsamixer under the default device I can find Pulseaudio with the playback and recording volume. Sometime for the device to show up in alsamixer you need to play something the first time you use it then to reboot.

Be sure to do all those steps and let me know where it fails. You have nothing else to do, no file to move.