Ultra++ fails after changing alsamixer settings (external_microphone_only) [resolved]

Hey there.

Since I was lucky enough to get the new profile external_microphone_only
I finally managed to get the external mic working (Thanks alot to @sbar).

I tested it by arecord -f cd -Dhw:0 | aplay -Dhw:0 to monitor the mic by headphone.
Worked like charm.

After I realized the onboard speakers are on with external_microphone_only loaded I decided to turn down speaker volume manual (Param is named “Speaker”, position 3 at alsamixer's [all]).

Unfortunatly the Ultra++ stops working after this little unimpressive tweak.

As soon as I try to playback some random mp3 by ffplay or reproduce the test mentioned above nothing seems to happen. Just silence.

I need to restore some unmodified factory preset first (like external_microphone_only) to get it back to work again.

Im pretty must lost about this causing some major failure. Can you plea provide some more help to me to get this working and maybe even understood?

Thanks alot!

Hey guy. Sorry, Im really handycaped by and can get it managed by myself. Can anyone help me out?

yes we will work on it now sorry for the delay

Sorry for the delay!..
I tried to reproduce here your problem on my hardware (P4 with PI 0S (2021-05-07), an external microphone, an external speaker and of course the Ultra + ):

1- I load the “external_microphone_only” profile
==>alsactl --file external_microphone_only restore
2- I start alsamixer
3- I execute the command
==>arecord -f cd | aplay (ultra is the default device)
I notice that the headphones and the speaker reproduce the sound of the microphone well
4- With alsamixer I cut the speaker (with Speaker)
I see the speaker goes silent but the headphones continue to work

It seems to work better than in your case …

But after 2 or 3 minutes, the sound quality decreases a lot.
(But it still works)

This is what I saw here …
I would say the problem is probably with the command “arecord -f cd | aplay” and using the pipe …
Maybe the solution lies in writing a specific program …

I remain at your disposal to help you solve this problem…