ULTRA++ Line IN - input

Hi there,
I’ve installed a ULTRA++ on my RaspberryPi4 (8GB RAM), and I saw no major issues on the installation phase, except for the systemd service installed not starting.
I’ve restarted the Pi, and I was able to test it successfully following instructions.

Now, I have an issue which I can’t figure out: I’ve connected a LINE IN to the middle 3.5mm jack, and I get no clean audio on the system. I do get some distorted, low audio (both on the built in speakers and on the headphones). I’m playing music on a phone and connecting it to the middle jack (which on the images from the site say LINE OUT and also on the board itself)
I have no clue what is happening, but the solo purpose for acquiring this hardware, was, so I could use the LINE IN (I’m capturing audio, doing a sound visualiser and outputting sound into HDMI, so I can listen to a turntable on my Sonos system).

Here are some details I’ve gathered from my system:

systemd service start

# systemctl start wm8960-soundcard.service
Job for wm8960-soundcard.service failed because the control process exited with error code.
See "systemctl status wm8960-soundcard.service" and "journalctl -xe" for details.

capture and output devices

**** List of PLAYBACK Hardware Devices ****
card 2: wm8960soundcard [wm8960-soundcard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 
[bcm2835-i2s-wm8960-hifi wm8960-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

  **** List of CAPTURE Hardware Devices ****
card 2: wm8960soundcard [wm8960-soundcard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 
[bcm2835-i2s-wm8960-hifi wm8960-hifi-0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

dkms status

wm8960-soundcard, 1.0, 5.10.17-v7l+, armv7l: installed

OS and Hardware

  • Linux raspberrypi 5.10.17-v7l+ #1403 SMP Mon Feb 22 11:33:35 GMT 2021 armv7l GNU/Linux
  • Debian 10.9
  • Raspberry Pi 4 Model B Rev 1.4

Please let me know if there is any other information you need. Thank you in advance for your help on this!

By the way, this is my current setup; i’m trying to remove the RCA to HDMI splitter from this diagram.

Hello Mgarces and welcome!

So the issue that the sound captured on the LINE IN (sorry we will modify the picture today).

Have you tried to run the script to set the Line IN ?

External line input and headphones output:

alsactl --file preset_lineIN-jack_input3

To save your own preset:

alsactl --file Mycustom_presets store

To restore your own preset:

alsactl --file Mycustom_presets restore

Hi! Thank you for your help!
I’ve tried running that script, and here is the output:

alsactl --file preset_lineIN-jack_input3 restore
No state is present for card b1
No state is present for card b1
No state is present for card Headphones

Still getting very low and distorted sound on the Ultra++ headphones; my ultimate goal would be to capture LINE IN and output sound to HDMI.

Can this be related to any conflict with PulseAudio?
No state is present for card Headphones

By the way,
The image I’m referring to, which I believe is wrong is this one: https://raspiaudio.com/wp-content/uploads/2018/08/ULTRA_listing_4-scaled.jpg.
Figure 8 says “Line out” and I believe it should say “Line IN”.

Thank you for your help in advance.

Just an idea run alsamixer and select the ULTRA++
then run the scrip again

Can you confim that you see the many settings in alasamixer?

I have done what you ask and I can confirm I do see many options in the alsamixer.

One thing I’m finding strange, is, even if lowering INPUT1 (external mics), and I capture audio on INPUT3 (line in), I can see the wave monitor (or using something like cli-visualizer); If I pause the input and tap my fingers close to the external microphones, the monitor reflects this; somehow the sound is getting also captured on the microphones, at the same time as the input.

Super confused with all this, hope you can help out.

There are many controls and easy to get confused at first so my advice is to use a known working configuration such as https://github.com/RASPIAUDIO/WM8960-Audio-HAT/blob/master/preset_lineIN-jack_input3

You were not able to apply the preset based on your previous error message, I will try soon to apply this alsa settings here to understand where could be your issue

Thank you!
I’ve cleaned my sdcard and started fresh, just to make sure I do things correctly;
I want to be able to input on the Ultra and output on the HDMI, but for now I only have onboard audio out (I’m mobile and I don’t have a screen attached to the Pi, so it doesn’t detect HDMI audio out).
I’ll update you soon with any news.

OK, progress… I was able to INPUT sound and OUTPUT via built-in jack.

sudo arecord -f cd -Dhw:1 | aplay -Dhw:0

I’m capturing on Ultra++ and playing it on Raspi jack.

I’ve also applied the script, and noticed some stuff in the sound changing; I’m also detecting a bit of noise and interference, which might be related with WiFi; I’ll test this at home with ethernet, to see if it improves.

Do you know how can I keep the sound always being captured and output? Do I have to always runn arecord and aplay ?