Volume Problem - Rasp 4 with Buster

I have successfully installed mic+ and passed the audio test with the button.The card is working well except that is impossible to control volume level neither from the main volume slider at the taskbar nor from 'audio control settings from the menu.
In order to minimize any conflict etc , I made a new clean install with just the os and the driver for mic+,the results are the same:The slider is moving but nothing happens.The volume level remains the same.Only mute is working.I tried as well alsamixer from cli with same results.Nothing changed.I noticed that is possible to change the level from inside any application is running, I mean if for e.g vlc is playing a mp3 is possible to volume up/down from the vlc volume control.
Kindly advise how can I fix this problem as this is a navigation project,and I am already out of time for giving the machine to my client


Hello pnt,

I tried again today with the last version of Raspberry PI OS 32 bit released 2021-01-11 32 bits and the volume control works on the desktop and with alsamixer, without changing anything.

Usually when you can’t change the volume this is because your sofware that makes the music is not using the virtual softvolume device created by the installation script and set as the default device. Try to list your playing devices by doing a :

aplay -l

then be sure that your software is addressing the default device as the default device for playback is ‘softvol’

if you can’t find the solution paste here your /etc/asound.conf to check