Volumio 3.251 and Ultra+

I purchased the RaspiAudio Ultra+ from Amazon because it was advertised as compatible with Volumio.
Unfortunately, I have yet to get any audio from the device using Volumio.

After half a day of reading, testing, and troubleshooting, I installed DietPi and I have managed to get audio from the Ultra+. At least I know the device works properly.

Coming down to my question.
How do I get Volumio working with the Ultra+?
I think I have reinstalled Volumio 3.251 almost 20 times and tried countless proposed solutions found on this forum and others.
I really want this to work, but I am loosing hope.
Is the Ultra+ not compatible with Volumio?
Should I replace it with a Mic+ or other DAC if I am planning to use Volumio?

Thank you in advance.

Hi Relax and Welcome! Let me try with the last version of Volumio, stay tuned

The Ultra is using the WM8960 codec just as the Waveshare so it is compatible

this user found this solution with the last version :

OK, I was able to configure Waveshare WM8960 with the latest Volumio OS build on Raspberry Pi

I have RPI Zero W and made the following steps:

1. Clean install Volumio OS (Volumio-3.198-2022-01-24-pi.img)
2. Initial network setup
3. Enable SSH
4. Add string to dacs.json
nano /volumio/app/plugins/system_controller/i2s_dacs/dacs.json
{"id":"wm8960-soundcard","name":"Waveshare - WM8960","overlay":"wm8960-soundcard,i2s-mmap","alsanum":"1","alsacard":"wm8960soundcard","mixer":"Playback","modules":["i2c-dev","snd-soc-wm8960","snd-soc-wm8960-soundcard"],"script":"","i2c_address":"1a","needsreboot":"yes"}
5. sudo volumio kernelsource
6. git clone https://github.com/waveshare/WM8960-Audio-HAT.git
7. cd WM8960-Audio-HAT
8. sudo ./install.sh
9. Select Audio Output:

** I2S DAC > OFF*
** Output Device > wm8960-soundcard*

I will try to test this tonight and report back. (CST timezone)
I did not think to or take the time to research the codec/chipset of the Ultra+ module yet.

Thank you.

Ok, I followed the directions in the post and when I reboot after step 8, the web interface is no longer accessible.
I can still ssh into Volumio, but the web interface no longer loads.

I noticed a warning during step 8 saying “Package raspberrypi-kernel is not available”
I have not been able to find a way to install this package or a replacement for the package.

Ok, never mind.
I realized that I missed putting a comma on the previous line in step 4.
I have successfully completed all of the steps.

Now I get an error when I try to play audio.
Something about failed to open ALSA.

could you send me the error screenshot please?

ok ok and you said that you have tried this ?

I have tried this install guide, both method 1 and method 2.
Maybe combining the knowledge from the first solution you provided with the knowledge in this solution will get it working.
Worth another look anyway.

Alright. I have an update.

Performing Method 1, I get audio, but it is quiet and crackly and the ultra+ module get very hot in just a couple minutes.
The reason it didn’t work the first time I tried this solution is because I tried to use the I2S DAC settings instead of the regular output device.

Performing Method 2, I managed to get audio after learning the above and the ultra+ module does not get hot.
The problem I discovered is that only some audio streams appear to work.
I can play the web radio stream labeled “ANTENA1 | 94,7 FM” but I randomly tried about a dozen other streams and received the error message in my June 9th screenshot.

I tried installing the Spotify Connect2 plugin.
I can connect my Spotify to it, but no audio and when I change the volume level, Spotify disconnects and returns to playing locally on my phone.