Wifi Connection Issue: Auth Expired at setup


I just got a Muse Luxe and I’m trying to set it up for Home Assistant but I can’t get it to connect to my router and I get Auth Expired error message. This is happening on either the precompiled version available or by compiling the sources and manually providing ssid and password in the yaml.

I tryed with my phone as hotspot and it connected right away but I can’t get it to work with my router.
I know the credentials are right as I have other esps running. I installed tasmota to test the wifi with something esle and it worked fine so it’s a esphome issue.
In the config I’ve also tryed to add a static_ip, fast_connect, power_save_mode and output_power but without any changes.
I’m running out of ideas to get it to work :confused:

Here are the verbose logs :

[C][wifi:038]: Setting up WiFi...
[C][wifi:051]: Starting WiFi...
[C][wifi:052]:   Local MAC: 64:B7:08:34:F5:F0
[V][esp32.preferences:059]: nvs_get_blob('3529742840'): ESP_ERR_NVS_NOT_FOUND - the key might not be set yet
[V][wifi_esp32:039]: Enabling STA.
[   126][D][WiFiGeneric.cpp:929] _eventCallback(): Arduino Event: 0 - WIFI_READY
[V][wifi_esp32:441]: Event: WiFi ready
[   228][V][WiFiGeneric.cpp:338] _arduino_event_cb(): STA Started
[   228][D][WiFiGeneric.cpp:929] _eventCallback(): Arduino Event: 2 - STA_START
[V][wifi_esp32:452]: Event: WiFi STA start
[VV][scheduler:226]: Running interval '' with interval=60000 last_execution=4294887385 (now=244)
[W][wifi:152]: Warning set: unspecified
[  4644][V][WiFiGeneric.cpp:360] _arduino_event_cb(): STA Disconnected: SSID: ***, BSSID: 1c:57:3e:63:66:f2, Reason: 2
[  4645][D][WiFiGeneric.cpp:929] _eventCallback(): Arduino Event: 5 - STA_DISCONNECTED
[  4651][W][WiFiGeneric.cpp:950] _eventCallback(): Reason: 2 - AUTH_EXPIRE
[  4658][D][WiFiGeneric.cpp:966] _eventCallback(): WiFi Reconnect Running
[  4665][V][WiFiGeneric.cpp:97] set_esp_interface_ip(): Configuring Station static IP:, MASK:, GW:
[W][wifi_esp32:482]: Event: Disconnected ssid='***' bssid=[redacted] reason='Auth Expired'
[W][wifi:630]: Error while connecting to network.
[D][wifi:673]: Retrying with hidden networks...
[I][wifi:303]: WiFi Connecting to '***'...
[V][wifi:305]: Connection Params:
[V][wifi:306]:   SSID: '***'
[V][wifi:311]:   BSSID: Not Set
[V][wifi:329]:   Password: [redacted]
[V][wifi:336]:   Channel: Not Set
[V][wifi:341]:   Manual IP: Static IP= Gateway= Subnet= DNS1= DNS2=
[V][wifi:345]:   Hidden: NO
[  8167][V][WiFiGeneric.cpp:360] _arduino_event_cb(): STA Disconnected: SSID: ***, BSSID: 1c:57:3e:63:66:f2, Reason: 2
[  8168][D][WiFiGeneric.cpp:929] _eventCallback(): Arduino Event: 5 - STA_DISCONNECTED
[  8175][W][WiFiGeneric.cpp:950] _eventCallback(): Reason: 2 - AUTH_EXPIRE
[W][wifi_esp32:482]: Event: Disconnected ssid='***' bssid=[redacted] reason='Auth Expired'
[W][wifi:630]: Error while connecting to network.
[D][wifi:673]: Retrying with hidden networks...

Anybody got ideas ?

Could you try setting your Wi-Fi credentials using the web interface, for example, at apps.raspiaudio.com? I think the improved Wi-Fi should be working, and you should have the option to set Wi-Fi credentials.

However, if it works on your phone, there might be a special character in your password or oauth method used. Try changing your router’s Wi-Fi password or setting another SSID on your router (most of them allow having multiple SSIDs on the same LAN).

I had a similar issue two or three weeks ago. I did change the wifi channel my router uses in the router settings from 1 to 11 (I think higher channels are usually less crowded). Worked in an instant. Never had any connection problems since then.
Best luck.

good to know, thanks for sharing!

Okay I’ve tryed a few more things:

  • via raspiaudio, when I add my wifi password it tells me something went wrong after some time (I don’t have the logs but I suspect it’s the same issue)
  • I saw in the verbose logs that sometime it wasn’t in the right subnet and with wrong dns, so I’ve manually added them in the config and it didn’t change the issue
  • I’ve setted up a new wifi ssid and password containing only letter and numbers but with no avail (I’ve made sure it was a 2.4ghz)
  • I’ve tryed your solution changing channel from auto to 11 or others but it didn’t change either. I’ve also messed around with band width, security protocols, wifi versions, transmission power but it didn’t do anything more
    I’m running out of settings to change in my router to try and fix this :confused:

I think my unit is defective.
I turn out that if I am 15cm away from the router it can’t connect. That’s why it was able to connect to my phone and not my router.
For good measures, I tried to connect to another brand of router at a different place, and it was the same issue
I’ve asked on amazon a return to replace my unit

please share your order number in private message here, thanks


Did you get my message ?
What do we do from here ?

I’m running in the very similar issue…
Tried almost everything mentioned here (static_ip, power_save_mode, output_power, various router configurations) with no effect…
In my case only after reinstalling the device software (via cable) it connects to the network, but as soon as it disconnects from the network (e.g. by turning it off and on) - it cannot connect again and again at all.
It got me believing that also my device is defective – @Raspiaudio how can I claim a warranty / replace speaker with a functional one?

Check your private mesages

I discovered that I need to set my computer’s wifi turned on and set to the same SSID as my Muse Luxe in order to get it to connect for setup via a direct USB connection (I have all my IoT devices on a separate SSID and subnet.)

I read in one of the notes that there might be an antenna fix or mod in the works. This device has the weakest connection in my house, despite the access point being less than 20 feet away. I’d be interested.