Cannot install ESPHome or squeezelite firmware [resolved]

Hi.

So I want to use speaker with Home Assistant.

1. Media player from ESPHome via browser

I am trying to install ESPHome from https://esphome.github.io/media-players/
Device is connected but when I try to install I get error:
Failed to initialize. Try resetting your device or holding the BOOT button while clicking INSTALL.

I do not see any obvious way to open the speaker so I guess I will not be pressing boot button.

2. Media player from ESPHome via ESPHome-Flasher

Next I think - let’s just install through ESPHome-Flasher. Now I just cannot find any way to download firmware from ESPHome media player. Is it just me? Is it not possible?

3. Squeezelite via browser

Trying from https://sle118.github.io/squeezelite-esp32-installer/
Error same as in 1. case.

4. Squeezelite via browser 2

From https://raspiaudio.github.io/
Error same as in 1. case.

5. Squeezelite via ESPHome-Flasher

Next I tried to install squeezelite via ESPHome-Flasher - no success:

ESPHome-Flasher-1.4.0-Ubuntu-x64.exec ~/atsiuntimai/squeezelite-esp32-master-v4.3-Muse-16-21254.bin

Auto-detected serial port: /dev/ttyUSB0
Connecting......................................
ESP Chip Auto-Detection failed: Failed to connect to Espressif device: No serial data received.

6. Squeezelite via esptool

esptool -p /dev/ttyUSB2 write_flash 0x0 ~/atsiuntimai/squeezelite-esp32-master-v4.3-Muse-16-21254.bi

Serial port /dev/ttyUSB2
Connecting......................................
A fatal error occurred: Failed to connect to Espressif device: No serial data received.

7. Debugging my PC

I also tried to flash both media player from ESPHome via browser and squeezelite via ESPHome-Flasher to Lolin D32 - everything works fine. So maybe not my PC/OS problem?

Any ideas?

Hi
There is a secret button IO0 in case the auto-bootloader fails.
Device turned off, use a paper clip thru the jack hole until you feel a click, maintain it pressed and turn it on. You should be in bootlader mode and ready to download.

Other possibility is that your are using a cable without data, try another cable.

Had to play around more to do the install but the secret button definitely worked. Thanks man! :pray:
How silly of me not find the button is secret

Where exactly is that “Secret button”? I can’t find it…
I have tried with the hole next to the m-USB port, the mic hole and the LED hole with no success. No button… and sadly I broke the mic or LED while searching for it…

The button is behind 3.5 mm jack so you have to insert pin/needle through the hole until you feel the click.

Now up and running. Thank you! :slight_smile:

Were you able to get the raspiaudio esphome firmware installed or just squeeze? I have the same error when trying to install the raspiaudio esp home firmware from the webloader, but squeeze loads just fine. I really want the muse firmware. Ive tried the secret button but no luck

Strange, if you are able to start loading using the the Squeezelite web interfac e it should work too with ESPHome too as they are using the exact same code
Be sure to have only 1of the 2 Chrome window open at the same time or the port com will be busy for the other one.

At first I could not get esphome firmware for some reason, but after flashing squeezelite I could flash anything from that point on ¯\_(ツ)_/¯

Hi,
I’m also unable to flash. (ESPhome, on muse proto).
I can just hold the IO0 button (since its a proto). But is there a way to tell its managed to get into bootloader mode? How long do i have to hold it? Which buttons should be flashing/lighting up?

  • Device is recognized in windows (isntalled the chipset driver)
  • Therefore cable is alsow orking (and verified with anotehr device)

If i press the IO0 button during the (failing) webinstall of ESPhome media player. A short beep is played and then the big LED that was white before turns yellowish.

flashed a regular ESP32 via the normal path (and that worked).

Hold io0 then push on reset, release both and you are in bootloader mode.

This is usually not necessary for the Proto, check if your on/off switch on the board.

left the board running overnight, somehow that seems to have resolved it. Now happily working.