Cannot install ESPHome or squeezelite firmware [resolved]

Now up and running. Thank you! :slight_smile:

Were you able to get the raspiaudio esphome firmware installed or just squeeze? I have the same error when trying to install the raspiaudio esp home firmware from the webloader, but squeeze loads just fine. I really want the muse firmware. Ive tried the secret button but no luck

Strange, if you are able to start loading using the the Squeezelite web interfac e it should work too with ESPHome too as they are using the exact same code
Be sure to have only 1of the 2 Chrome window open at the same time or the port com will be busy for the other one.

At first I could not get esphome firmware for some reason, but after flashing squeezelite I could flash anything from that point on ¯\_(ツ)_/¯

I’m also unable to flash. (ESPhome, on muse proto).
I can just hold the IO0 button (since its a proto). But is there a way to tell its managed to get into bootloader mode? How long do i have to hold it? Which buttons should be flashing/lighting up?

  • Device is recognized in windows (isntalled the chipset driver)
  • Therefore cable is alsow orking (and verified with anotehr device)

If i press the IO0 button during the (failing) webinstall of ESPhome media player. A short beep is played and then the big LED that was white before turns yellowish.

flashed a regular ESP32 via the normal path (and that worked).

Hold io0 then push on reset, release both and you are in bootloader mode.

This is usually not necessary for the Proto, check if your on/off switch on the board.

left the board running overnight, somehow that seems to have resolved it. Now happily working.

I’n having the same problem with my Muse Luxe as @aurelijus

Picked it up last month with some proto boards. Was working perfectly for a couple of weeks and then one day, it just stopped responding (had it integrated with ESPHome on Home Assistant).

Tried reflashing every possible .bin using the web-based loaders - no luck - can’t connect to it.

Opened the speaker up to take a look and when it’s connected to the computer, Windows does make the connection noise but not getting anything lighting up on the board.

Went through all the steps that have been mentioned in the thread (and used the hidden bootloader button) but nothing is being seen.

Tried ESPHome-flasher:

Using 'COM7' as serial port.
Unexpected error: ESP Chip Auto-Detection failed: Failed to connect to Espressif device: No serial data received.
For troubleshooting steps visit:

Loaded it into it with serialtools and got no data

No luck with espefuse v4.5.1

A fatal error occurred: Failed to connect to Espressif device: No serial data received.
For troubleshooting steps visit:

It’s not the cable or my drivers - the Proto boards that I set up at the same time can be monitored through serialtools (and it’s even the cable that came with the Muse Luxe!).

@Raspiaudio - does that sound like it’s dead?

It’s probably not dead but a software crash that does not allow it to go in autoboot loader mode to be reflashed.

You need to use the secret button, please follow these steps:
1-Turn it off, usb cable plugged, go to select for example Luxe-Bluetooth
2-insert a paperclip in the jack plug on the back until you feel a click (it requires some locksmith skills), while maintaining the button pressed turn the device on, you can release the paper clip
3-select the right com port and upload

If it fails you can also try to push the secret button while it is trying to download.
If you are not sure if you pushed the button correctly you could also open a serial console: turned off, push the button, turn if on and you should see a message like “waiting for download”…

No luck with the secret button - tried installing but I’m still getting:

Failed to initialize. Try resetting your device or holding the BOOT button while clicking INSTALL

I’m getting nothing on serial console. It sees the port is open and connects but there’s no message when I press the button like you instructed.

Have tried a few days later and still no luck with the Muse Luxe :face_exhaling:

(Although in that time, I have ordered more proto boards because they’re working fantastically for my projects!)

Hello, having exactly the same issue here.
Let me mention that I just received the ESP Muse Luxe with an USB-C port (not micro USB as expected).

After installing the driver CP210x drivers I could see the serial port as expected for all ESPs.
When starting the installation I just receive the “Installing” popup and nothing else.

After some time or when disconnecting the cable I also get the message:

Failed to initialize. Try resetting your device or holding the BOOT button while clicking INSTALL.

Pressing the tiny button in the jack plug (using a paperclip) even did not work.
Using further cable(s) did not help as well.

Another message came up when I waited several minutes for the

Can you please describe me again the exact sequence how to flash the device (currently the simple Bluetooth image seems to be installed)? If I cannot get Esphome flashed, I will send the device back.

BTW: In the meantime I have flashed so many ESP devices and all of them I could get working. But maybe ESP Muse Luxe is to complicated to me.

Cheers, red

Hi !

As a test could you please try

let me know

I did all possible ways and combinations:

  • Different images: (different variants), ESPHome Media Players or Esphome (Add-on in Home Assistant)
  • Different USB cables: USB-C to USB-C, USB-A to USB-C (the original, another one)
  • Different combinations to start the device: with bootloader combination / secret, without;)

Finally, after rount four hours trial and error, I got it working :frowning: :

  • in Esphome directly with this YAML-coding
  • USB-C to USB-C cable
  • Steps:
    1. disconnected the cable once shortly before the last run
    2. reconnected cable
    3. switched device off
    4. pressed “Retry”
    5. chose serial port > Connect
    6. pressed secret button (jack plug) > hold it
    7. switched device on (on/off switch) and released the secret button button again

Then it changed to “Preparation Installation” > “Installation”.
Untitled Project

Why isn’t it well documented - especially for the very first run??? There is no clear documentation delivered with the device and even not in the internet !! Sorry but this needs to be improved! Otherwise it’s useless for many people!

Unfortunately, with this device too often it looks like a “try” for many - and some unfortunately fail too.

Your post gave me a little hope to get my dead device running. But all I tried failed. Unfortunately I can’t return it to Amazon, it’s to late. Now I hope I’ll get some help from Raspiaudio. Still waiting.

I also tried without any success:

    ~  --chip esp32 --port /dev/ttyUSB0 erase_flash                                               2 ✘  8s  v3.2
Serial port /dev/ttyUSB0

A fatal error occurred: Failed to connect to ESP32: No serial data received.
For troubleshooting steps visit:

Dear All,

The upload method via the web interface is relatively new, and all websites utilizing it rely on ESP Web Tools. A single update from them could potentially cause the auto-loader to malfunction. Since every ESP device is slightly different, changes to the timing before the reset could render the upload non-functional for all websites you have mentionned.

Consequently, an update from their end might lead to unpredictable behavior in the Luxe, which I cannot control. For instance, I was unable to upload a few weeks ago using a Chrome browser on a Mac, but it worked fine on a PC.

To accurately diagnose the issue, we should revert to a known reference point by employing the native method to upload firmware. -p /dev/ttyUSB0 write_flash 0x0 my_image_to_burn.bin

on windows -p COM10 write_flash 0x0 my_image_to_burn.bin

to use for example with this bin file for a bluetooth speaker

how to install esptool

If you have an issue with the web update, could you tell me what OS are you using (windows 11, OSX…) and your chrome version?


I think I have found the issue :slight_smile:
The new pilot for windows for serial converter CP2104 is causing issue, for this to work you need to install the 2020 version

I have also made a local copy just in case here

So on Windows when you go on device manager do an update driver and point on this uncompressed directory. If you have alreday installed the newest drivers you need to uninstall them don’t forget to click the box here :

(sorry it is in french )

Referencing this issue: Muse Luxe esphome loud buzzing sound - #18 by red

Maybe it is related.