EspMuse with squeezelite-esp32 doesn't start after battery was drained

I was using my EspMuse for a few weeks now, until I drained the battery yesterday completely by having it not plugged in for a while. Now the box doesn’t start (after switching on the top LED doesn’t turn on and the device doesn’t connect to the network. It also doesn’t start an wifi access point. it just looks completely dead.
I already tried leaving it plugged in for a while, and tried starting it with or without power (usb-)cable.
Any hint is appreciated!

Hi Polt, Are you using Squeezelite?

I’m assuming that you are using Squeezelite, this behaviour has been reported in the Slimproto forum, you could check over there searching for the Muse Luxe thread.
But try to open a serial terminal, you should still have the command prompt and you can try to go in recovery mode :


What I think is happening is that Squeezelite have a hard reset while it is writing some config data, resulting in some data corruption.

Hi, thanks for the quick reply. Yes, I’m using Squeezelite.
Bummer, is the serial console the last resort ? How do I find documentation to do this ? I don’t really fancy debugging this, any other way of hard-resetting the device for recovery ?

Just for reference, I could indeed simply reflash the squeezeliteML.bin binary mentioned in Multirooms with SQUEEZELITE with ESP32 MUSE PROTO

screen /dev/ttyUSB0 115200

Wait a bit, then

esptool -p /dev/ttyUSB0 write_flash 0x0 squeezeliteML.bin  

(not sure if the nvs_erase_wifi_manager and restart steps are needed though.