MUSE LUXE speaker with Squeezlite (Logitech Media server)

I thought so. Then, what’s next. Disconnect usb cable and turn off? Wait 10 minutes and try again?

Alright got it working. Just switched off, removed usb cable and started again. This time a progress bar and everything went fine.
One q. I installed the esp32 plugin in lms to use the equilizer but it does not show anything. Rebooted the LMS server (PcP) twice.
Running Logitech Media Server Versie: 8.1.2 - 1614990085 @ Sat Mar 6 02:41:13 CET 2021 on piCorePlayer | piCorePlayer v7.0.1 | www v00016 | linux 5.4.83-pcpCore-v7 | piCore v12.0pCP | Squeezelite v1.9.9-1386-pCP

I had a similar problem with a SqueezeAMP (see here). Philippe offered some advice, and eventually some combination of those steps worked for me. I’m not sure exactly what fixed it for me, but if you follow the advice in that thread you may get this resolved. I suspect a browser cache issue may have clouded the issue for me.

Good morning,

I just tried the latest firmware (v0.4 19.01.2022 17:05 according to the git log), but I have never managed to get the buttons to work on the Squeezelite build.
I wrote MUSE colleagues about it, since I thought it would be a hardware problem. Oliver proposed loading the initial firmware without LMS, and here each button react and say blip loud and well.

Now the question to this latest firmware 0.4, I have understood there is no configuration needed to make the buttons react. Of course it would be nice to control volume and pause when needed.

this is the config I see now:
[{“gpio”:32, “type”:“BUTTON_LOW”, “pull”:true, “debounce”:10, “normal”:{“pressed”:“ACTRLS_VOLDOWN”}},{“gpio”:19, “type”:“BUTTON_LOW”, “pull”:true, “debounce”:40, “normal”:{“pressed”:“ACTRLS_VOLUP”}},{“gpio”:12, “type”:“BUTTON_LOW”, “pull”:true, “debounce”:40, “long_press”:1000, “normal”:{“pressed”:“ACTRLS_TOGGLE”},“longpress”:{“pressed”:“ACTRLS_POWER”}}]

I will now try with the cool chill config and see if I get the buttons to react…

but, no chance… no reaction at all???

Any other ideas for me to try?


Hi Richard - that’s strange. I was on 0.3, but just updated to 0.4 and the buttons do indeed work without any intervention - they are properly configured by the bin file.

Take care when editing the configuration - any misplaced comma or quotation character will cause a problem, and note that the quotation characters seem to get changed to the curly sort, rather than the straight sort, when pasted into messages here. For completeness, I just pasted my pre-formatted ‘buttons’ string from 8 days ago into a new ‘buttons’ key and changed actrls_config to match and it worked, so the pre-formatting in that message has the right quote type.

Hi Richard - my apologies, I’ve just realised that it was you who pointed out the issue with the quotation characters!


Can you post instructions & photos on how to open speaker ?
SqueezeAmp supports a small OLED display - it would interesting to check if one could be added and mounted behind grill.

Hi Bpa,
We are preparing something to use the grove port behind to plug a screen, but not sure that it will still be visible behind the grill, we were more thinking about some kind of a 3d printed extension, not sure how yet.

I took the grill off. Is it a passive radiator in the centre ?
On RHS it looks like space enough for a 0.91" 128x32 type screen if grill had a small cutout. I assume board & battery are behind panel.

A 3d printed addon to top/side with floating cable could look a bit “odd” and unit would not be as neat.

Yes the middle thing is a passive radiator.

Hi Chris,

yes, I have tried both the config included in the binary and adding your’s as separate config, but the buttons does not react at all. But as stated above, the initial firmware without LMS functionality do react pressing them. So there is no hardware problem as I can see?

I believe I have “burned” the firmware correctly, so I really do not know what to do now.


I’d love to obtain a luxe speaker to use in house and at work, as a LMS client.
But I don’t seem to be able to buy some as it isn’t offered in is there any way I can have one send to the Netherlands


I bought mine direct of the raspiaudio website main page here. Not a problem to get it to Germany.


Depending on where you live in the Netherlands, it may be an option to get the speaker delivered at a pick-up location in Germany close to the border with the Netherlands. That is what did. If you live far from the border with Germany this is probably not an attractive option.

@Jarr3, I don’t see an option to buy the ESP Muse Luxe speaker directly from this website.

I thought about that after reading your comment earlier, but I figured I didn’t want it that bad :).
Just wondering why it isn’t delivered in the netherlands, or did I miss a Nexit :slight_smile:

anyhow, maybe raspiaudio is willing to add or just to put it also back on their own website.


We will try to add the Luxe in UK, NL in the next 7 days. But our inventory is low and we should be out of stock soon. :sweat_smile:

But in 2-3 weeks we have a large batch that will be ready. It will be used to open Amazon USA and
complete Europe stock.

We have stopped direct orders from as it costs us too much and I hate going to the post office :rofl:

Btw, if you scroll down on the raspiaudio home page to the ESP Muse Luxe speaker you can still add this product to the shopping cart, and then check out the shopping cart and fill in your address and credit card details. So it seems that the direct order possibility is still there. I don’t know however if Raspiaudio will accept your order and go to the post office…

I’d also like to know how to crack this baby open.

I’m getting less than a day standby time using the hardware power off switch.

This is a real bummer, I charge it overnight and it’s dead 24hrs later without ever turning it on - do i perhaps have a defective unit?

I’m truely impressed at what you’ve managed to achieve mass producing this unit for the price but i’d love to have something that doesn’t drain battery while turned off.

I’d be happy being able to add another couple of 18650s and adding a proper mechanical toggle switch to enable the battery for times when we’re off grid so any ideas as to purposefully open the unit up would be great!

I seem to have the same power problem. Left mine playing when i left home. A few hours later and the espmuse was totally dead, even a full night charge did not help. Now i’m flashing the firmware again and will do so when finished , now with the latest fw. (just saw its renewed…)

Done. Latest firmware and the LMS plugin somehow is working now. Did not change anything to LMS.

The grill comes off easily - just need to find a fine strong tool to poke into holes around the edges and leverage it up a bit at a time going around.

Behind the grill there are screws. Don’t know anything further.