Squeezelite-ESP32 - Muse Proto - Home Assistant

Hello to all

I received the Muse Proto PCB yesterday. I install the Firmware successfully from the following link https://esphome.github.io/media-players/

I added the device successfully to my wifi network and also to the Home Assistant as you can see in the picture bellow

image

But when I try to play any thing in the speaker connected to the Muse Proto PCB, I always received the information in the Home Assistant that is nothing playing

How can I test this ? Is there anything to perform before these steps ?

Thank you in advance for your help and support

I just still trying to play over the Muse proto board without sucess but over the browser I’m able to listening the same radio that I’m try to use in the muse proto board … I there any way to test this ? Thank you

I had the same problem. But got it to work by installing the ESPHome add-on in Home Assistant. Just click the blue “Add-on” button on this page if you don’t have it: https://esphome.io/guides/getting_started_hassio.html

After that I went to the Add-on UI in Home Assistant. There it shows a list of all my ESPHome devices and also the Muse Proto one. I clicked the option to adopt the device and after waiting for the build and upload of new code it worked fine.

(The ESPHome won’t show in the sidebar unless you choose to show it there from the ESPHome add-on.)

1 Like

Thank you for your reply :smiley:

I also have the Muse Proto board added in the ESP addon installed and adopted

but I still not lintening any sound from the Speaker …

I also removed all from the addon and the integrations and start all again without success for now

Thank you and best regards

That is strange. Maybe you can try to install the Squeezelite version and see if it works as a regular Bluetooth speaker? Actually I had the Squeezelite firmware installed first and then I tried with ESPHome.
The Squeezelite version can be installed from here: https://raspiaudio.github.io/

And I guess you didn’t cut the trace on the backside of the board to disable on-board speakers? :slight_smile:

1 Like

Once again thank you for your reply

I tested this firmware Squeezelite and yes I’m able to listening from the attached speakers over the bluetooth :grinning: now I know that the problem is not in the speaker or in the muse proto board also

I try to install again the Other firmware from the https://esphome.github.io/media-players/ added the device to the Home Assistant and also in the addon ESP addoping again the same device that I have deleted, and I’m facing the same issue I’m not able to reproduce any sound in the speaker, I also tested other devices like the webbrowser to listening the same webradio from the Media in the home assistant and it works.

Thank you and best regards for your support

@Raspiaudio

Can you please help me in this issue ?

Thank you for your support

Hi, I’m not sure how Squeezelite will prioritize Bluetooth and audio coming from local IP Streaming.
Just an idea, try to disable bluetooth and/or turn off bluetooth source, reboot everything and try again. Any change?

1 Like

Hello Thank you for your reply :grinning:

I already tested this also with a different firmwares like a reported in the previously posted. The ideia is to use this card/board integrated in the home assistant as a streming source for the audio radio online etc

Thank yoy

Hello sorry it has been a crazy week, I will try this next week, but this is strange because I have tried it a couple week ago, I will let you know.

Hello

Ok thank you I will wait

Thank you for your support

Hi,

Just made a simple tutorial, let me know which step is not working for you

thx

1 Like

Thank you for your work and sharing.

But I still facing the same issue I’m not using the Muse Luxe but the muse proto board I sucefly intsalled the proto board in the Home Assistant as you can view the device is online

image

But when I try to play any sound the speaker doesn’t work I already tested the speaker also the board with other firmware like I mentioned in a post before but with the firmware and the spekaer with this firmware I’m not able to put the speaker working

Can you please help me in order to find a way to test or to check the logs?

Thank you and best regards

Can you share your logs? and give details about the version of HA hat you are using, if I can’t solve it I will ask help to HA team.

Hello

And sorry huge delay in a reply abou this subject

Today I tested again with the last firmware update on the ESP muse PCB board

And the problem persists I can’t listening anything from the speaker connected to the PCB i tested with the web radios and also with text to speech

Regarding the logs what kind of logs do you need ? From the ESP? Regarding the HA version is the last one Home Assistant 2022.9.1

Hello team

Any news about this subject?

Can you please reply me in order to try solve this issue?

Thank you in advance for your support and best regards

Hello team @Raspiaudio

Any news about this subject?

Can you please reply me in order to try solve this issue?

Thank you in advance for your support and best regards

Hello,

Have you tried to post you isse on https://discord.com/invite/c5DvZ4e ?
I will also give it a try next week, sorry for the delay on this