ULTRA++ installation guide

Yes we have noticed too, this is not faulty hardware. We are working on it.

1 Like

We have updated the Git to fix the left channel volume issue

1 Like

Hello,
Could you please answer the question?
With the “speaker-test -l5 -c2 -t wav” test the speakers work!
How can I also test the on-board microphones?
Do you have an on-board microphone / speaker test scrypt?
For my project this is very important, thank you.

Please don’t abandon me, thank you.

I’ve changed your username to SGI, and to record you can use all available linux commands, in the “method1” script by default onboard microphones are enabled.

you can use arecord command, see examples typyin “man arecord” or here : https://linux.die.net/man/1/arecord

Thanks, already using new values and they work better (-: Can you add licensing info to that repo? I’d like to use i2c init sequence for baremetal pi drivers.

just added a license

1 Like

all fresh instances nothig extra installed.

please try the method 1 in the first message of this thread, and if you have any error message please send them here.

I also tried Volumio and no luck followed your instructions.

Method 2 updated today with a new installation script form Seed studio. Working great. So we now have method 1 and 2 fully functional, thank for your patience.

Just recently tried this. I have two 4bs with latest fresh copy raspian 32bit stacked with x728 UPS and the ultra+s. I was able to get this working before like maybe a year ago with no issues, but now it seems it works on one but not the other. only difference between the two are x728 versions are 1.3 and 2.1(works on this one). Also have a raspi touch screen with the one with x728 1.3. so basically the one with the screen and the x728 1.3 is not working. cant see the card on the drop down, raspiconfig or alsamixer.

Hi,

For method 2 full control:

git clone https://github.com/RASPIAUDIO/ultra2 57
cd seeed-voicecard
sudo ./install.sh
sudo reboot

Are you sure it is not git clone https://github.com/respeaker/seeed-voicecard instead of git clone https://github.com/RASPIAUDIO/ultra2 57 ?

Thank you.

indeed this is more up to date

Hey, it is possible to disable the onboard microphones? even if I change the alsa preset the microphones still work.

Hi Markortu
I have the same issue and I think this is a driver issue. I’ve put on our task list to try to send directly commands to the codec to disable onboard mic, will post result here.

thx

Hi,
I’ve followed the guide as-is in the top post

At this step:speaker-test -l5 -c2 -t wav

i get

speaker-test 1.2.4

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -19,No such device

I have reinstalled per the next step

cd WM8960-Audio-HAT
sudo ./uninstall.sh
sudo ./install.sh

I am using a pi zero 2 w, with ultra++ hat, installed on Raspberry Pi OS Lite per rhasspy docs.

I note some conflicting advice in some of the comments about outdated drivers, and can see the top post was updated back in april. Do I need to be using a different driver? I want the headphones out and onboard microphones for this project.

Lastly: > `cd WM8960-Audio-HAT

sudo ./uninstall.sh
sudo ./install.sh`

in the guide should this not be cd ultra2? I don’t have a WM8960xxx directory that I could see.

Hi

Have you tried method 1 or method 2?
I have never tried on the lite version of PI OS

let me know and will give it a try

Hi, this was with method 2

I have tried on the full OS and on the lite a few times, multiple reinstalls of the driver script in the top post and all on fresh installs of RaspOS.

The audio output options in the desktop do not have the hat as shown in your screenshot - and I have found this error:

Building module:
cleaning build area...
make -j4 KERNELRELEASE=5.15.84-v7+ -C /lib/modules/5.15.84-v7+/build M=/var/lib/dkms/seeed-voicecard/0.3/build......(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.15.84-v7+ (armv7l)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.
mkdir: cannot create directory ‘/etc/voicecard’: File exists
git init
Reinitialized existing Git repository in /etc/voicecard/.git/
git add --all
git commit -m "origin configures"
On branch master
nothing to commit, working tree clean

I have attempted the fix noted here:

with the same error after running uninstall / new install

aplay -l =

**** List of PLAYBACK Hardware Devices ****
card 0: vc4hdmi [vc4-hdmi], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 [bcm2835-i2s-wm8960-hifi wm8960-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

which reads to me that the hat is being detected, yet it’s not available in the GUI

attempts to install the scripts to default output to the onboard speakers

pi@masterbedrhasspispeaker:~/ultra2 $ alsactl --file preset_onboard_microphones_input1 restore 0
No state is present for card vc4hdmi
alsa-lib main.c:1014:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2
Found hardware: "vc4-hdmi" "" "" "" ""
Hardware is initialized using a generic method
No state is present for card vc4hdmi
pi@masterbedrhasspispeaker:~/ultra2 $ alsactl --file preset_onboard_microphones_input1 restore 1
No state is present for card seeed2micvoicec
alsa-lib main.c:1014:(snd_use_case_mgr_open) error: failed to import hw:1 use case configuration -2
Found hardware: "simple-card" "" "" "" ""
Hardware is initialized using a generic method
No state is present for card seeed2micvoicec

Above results are from rasperrypi OS 32bit + method 2 install on a fresh install on sd card.

Above results are from rasperrypi OS 32bit + method 2 install on a fresh install on sd card.
On the GUI when doing a right click on the speaker can you select the device like this ?